Установка драйверов устройств на мобильной платформе 1С

Уже в который раз после внедрения драйверов мобильной платформы в свою конфигурацию мобильного приложения на базе 1с, я сталкиваюсь с проблемой установки драйверов. Каждый раз решаю эту проблему, но к сожалению по происшествии времени решение забывается и приходится все вспоминать снова.

Итак мобильную платформу берем на users.1c.ru. Библиотеку подключаемого оборудования для мобильных приложений берем там же. Далее производим установку и следуем инструкция по внедрению. Все довольно тривиально, порядок установки подробно описан в мануалах.

После внедрения библиотеки в свою конфигурацию, для того, чтоб они стали доступны драйвера нужно проинициализировать. Я не сразу понял, как и зачем, но в итоге пришел к следующем решению.

  1. Создаем общую форму. Добавляем в нее 2 команды. Команды перетаскиваем на форму. В итоге получаем такой код в модуле формы,
&НаСервере
Процедура ОбновлениеБиблиотекиНаСервере()
	МенеджерОборудованияВызовСервераПереопределяемый.ОбновлениеБиблиотеки();
КонецПроцедуры

&НаКлиенте
Процедура ОбновлениеБиблиотеки(Команда)
	ОбновлениеБиблиотекиНаСервере();
КонецПроцедуры

&НаСервере
Процедура ОбновитьПоставляемыеДрайвераНаСервере()
	МенеджерОборудованияВызовСервераПереопределяемый.ОбновитьПоставляемыеДрайвера();
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьПоставляемыеДрайвера(Команда)
	ОбновитьПоставляемыеДрайвераНаСервере();
КонецПроцедуры

Команда обновляет МенеджерОборудованияВызовСервераПереопределяемый.ОбновлениеБиблиотеки(); обновляет библиотеки, вторая МенеджерОборудованияВызовСервераПереопределяемый.ОбновитьПоставляемыеДрайвера(); как раз устанавливает наши драйвера в конфигурацию.

Правильно будет наверное сказать:

Заполняет предустановленные драйвера из конфигурации в текущую базу.

2. Вторым шагом создаем Общую команду которая будет вызывать нашу общую форму инициализации, и пропишем в ней открытые формы.

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	ПараметрыФормы = Новый Структура("", );
	ОткрытьФорму("ОбщаяФорма.ФормаТехСервис", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);
КонецПроцедуры

Общую команду отразим в командном интерфейсе. Дальше нужно на каждом устройстве запусить эту форму, и выполнить команды.

Posted in 1C

Добавить комментарий

Ваш адрес email не будет опубликован.